Actualitzar el firmware del Boox Wolder correctament

Si no teniu ni idea del què és el firmware, o el Boox Wolder… no cal que continueu llegint.

 

Si pel contrari heu arribat aquí després d’infructuosos intents d’actualitzar la ditxosa maquineta… Esteu de sort!

 

Tot es troba a internet, però no és senzill. Ara ho simplificarem molt i molt.

El Boox és un llibre electrònic que per aquestes contrades ha comercialitzat la casa Wolder. És un bon aparell, el que falla és el suport tècnic (inexistent) que faciliten els qui tant alegrement comercialitzen l’aparell.

Resulta que el distribuïdor (no goso dir-li fabricant, ja que els de wolder no fabriquen res, si de cas seria Onyx International qui ho fa) en un moment determinat d’eufòria encara facilitaven actualitzacions per als seus aparells (concretament per al model Boox A60, parlo). I la darrera actualització va ser la versió de firmware 1.4 20100901. I va ser la darrera no perquè la casa mare (Onyx International) deixés de facilitar-los actualitzacions, sinó perquè algú va cometre un error imperdonable i no hi havia manera de seguir actualitzant l’aparell.

Bé, doncs aquí acaben els vostres maldecaps, ja que a internet ho expliquen tot divinament, encara que en anglès i potser per alguns és complicat d’entendre.

Per començar, el Boox es basa en una versió de Unix molt bàsica, pel que és susceptible d’executar comandaments no previstos en un principi pel fabricant (això a títol merament informatiu, no cal pas que hi toqueu res! Més ben dit, NO hi toqueu res, encara convertiríeu l’ebook en una esplèndida  però prematura ferralla tecnològica!). El que si que ens caldrà és executar alguns passos molt senzills per a permetre desbloquejar el kernel de l’aparell.

Us deixo les instruccions per a solucionar el problema, però ULL! Realitzeu qualsevol modificació sota la vostra entera responsabilitat, ja sabeu que jugar amb el firmware pot acabar amb la vida de qualsevol aparell, i aquest no n’és cap excepció! A mi m’ha funcionat i per això crec que pot interessar a altres persones:

En aquesta pàgina ho explica tot. És imprescindible seguir exactament els passos del primer post, concretament la darrera part, i cito:

Els següents passos només s’han d’aplicar si el vostre aparell actualment té la versió de Wolder 1.4 amb el codi de data  20100901 instal·lat i et trobes que no pots actualitzar el firmware:

1. Descomprimeix l’arxiu i col·loca tots els arxius dins el directori font de la targeta SD (preferentment prèviament formatejada )
2. Engega el teu Boox i vés al directori font de la targeta SD on acabes de copiar els arxius.
3. Clica sobre l’arxiu que s’anomena: kernel_update.oar
4. Veuràs durant uns instants una icona de rellotge pampalluguejant. Desapareixerà de seguida
6. Col·loca qualsevol actualització del firmware al directori fons de la targeta SD. (en el meu cas he utilitzat el darrer disponible: 1.5.1 20110629)
7. Actualitza el dispositiu (cal extreure primer el llapis, obrir la part superior de la carcassa posterior, amb la punta del llapis presionem el botó on hi diu RESET mentre mantenim apretat el botó OK de la part del davant del dispositiu. Deixem d’apretar el botó de RESET però encara mantenim uns segons apretat el botó de OK. Quan apareix a la part inferior de la pantalla que s’està actualitzant, podem deixar d’apretar el OK. I paciència, que ja està tot.

 

Els arxius necessaris per a procedir a fer això són aquí sota, simplement baixeu, descomprimiu i copieu tots els arxius a la SD directament:

Arxius per reparar l’error de Wolder

Arxius per axtualitzar a la versió 1.5.1 20110629 

Sort en les actualitzacions!